Requirements

Software installed on your system:

Colmena is written in JavaScript using NodeJS and NPM.

The minimal versions required are Node v6.9.x or higher and NPM v3.x or higher.

Use the following commands to verify the versions installed:

node -v
npm -v

If you don’t have NodeJS and NPM installed on your machine please download and install it.

Globally installed Node packages:

Once you have NodeJS and NPM installed it’s time to install a couple of global dependencies.

Colmena expects the following packages to be installed globally:

  • Lerna
    • Manage the project mono repo and package inter-dependencies.
  • Angular CLI
    • Run, build and test Angular applications.
npm install -g lerna @angular/cli

Use the following commands to verify the packages are installed:

lerna -v
ng -v